Focus XR5 flat spot
Welcome, Guest. Please login or register.
Did you miss your activation email?
December 17, 2017, 05:51:12 PM

Login with username, password and session length


Members
Total Members: 12154
Latest: Divia
Stats
Total Posts: 484259
Total Topics: 20105
Online Today: 50
Online Ever: 354
(August 08, 2017, 07:07:23 PM)
Users Online
Users: 4
Guests: 47
Total: 51
Recent Topics
[December 16, 2017, 07:48:32 PM]

[December 16, 2017, 09:11:46 AM]

[December 15, 2017, 08:07:49 PM]

[December 15, 2017, 03:28:50 PM]

[December 15, 2017, 01:30:40 PM]

[December 14, 2017, 10:17:58 PM]

[December 14, 2017, 12:09:13 PM]

[December 14, 2017, 12:08:22 PM]

[December 13, 2017, 11:48:08 PM]

[December 13, 2017, 05:00:19 PM]

[December 13, 2017, 04:55:59 PM]

[December 13, 2017, 11:08:14 AM]

[December 12, 2017, 08:36:58 PM]

[December 06, 2017, 03:15:25 PM]

by TD
[December 05, 2017, 03:46:27 PM]
Pages: 1 [2]  All   Go Down
  Print  
Author Topic: Focus XR5 flat spot  (Read 856 times)
XR5TURBOTRENT
Into the peak torque!


Karma: 0
Offline Offline

Posts: 11



« Reply #15 on: December 04, 2017, 04:51:19 PM »

Melanie Mel she's done 159,000 Km's. I've never owned an XR5 before so maybe we have the same issue. Torque Reduction maybe
Report to moderator   Logged
buzz819
Torque Superhero.


Karma: 0
Offline Offline

Posts: 36


« Reply #16 on: December 04, 2017, 06:11:28 PM »

Have a look here;

http://www.fordxr5turbo.com/forum/index.php?topic=19104.0

Buzz
Report to moderator   Logged
mattyc35
Century Post Club


Karma: 0
Offline Offline

Posts: 443



« Reply #17 on: December 04, 2017, 07:27:10 PM »


That was my post, I traced the issue (in my case)(thanks Rocker) to the Turbo Smart bypass valve I fitted not working so well with Collins tunes.
Report to moderator   Logged

GGR intake, Radtec intercooler, Collins CP320, Decat pipe.
GGR engine mount, RS Clutch, Elevate TCV, Mongoose Exhaust.
MelanieMel
Coming on Boost


Karma: 0
Offline Offline

Posts: 8


« Reply #18 on: December 05, 2017, 04:41:14 AM »

Melanie Mel she's done 159,000 Km's. I've never owned an XR5 before so maybe we have the same issue. Torque Reduction maybe
Ok, possibly is the same. Mines done 133,000 so yeah they are both getting up there km wise. Mine is booked in at Ford (in NZ) next week. Fingers crossed it's an easy fix!


Sent from my iPhone using Tapatalk
Report to moderator   Logged
MelanieMel
Coming on Boost


Karma: 0
Offline Offline

Posts: 8


« Reply #19 on: December 05, 2017, 04:41:44 AM »

Are you in melbourne?
I'm in NZ.


Sent from my iPhone using Tapatalk
Report to moderator   Logged
Robbo
Uncle Chop Chop
Twin Turbo Post Master!
*

Karma: 87
Offline Offline

Posts: 12,512


The Mako - RS powered 😏


« Reply #20 on: December 05, 2017, 10:16:04 AM »

Often, a "flat spot" can be attributed to a dirty MAF or MAP sensor.

They can be self induced with a CAI also, by disrupting smooth air flow.
Report to moderator   Logged

Cheers, Rob Smiley              vvvvvvvv My build Thread vvvvvvvv
http://www.fordxr5turbo.com/forum/index.php?topic=20139.0
mattyc35
Century Post Club


Karma: 0
Offline Offline

Posts: 443



« Reply #21 on: December 05, 2017, 02:41:42 PM »

http://www.dreamscience-automotive.co.uk/product/products/ford-focus-st225-mk2/focus-st225-Sensors/st225-sensor-pack.html
Report to moderator   Logged

GGR intake, Radtec intercooler, Collins CP320, Decat pipe.
GGR engine mount, RS Clutch, Elevate TCV, Mongoose Exhaust.
XR5TURBOTRENT
Into the peak torque!


Karma: 0
Offline Offline

Posts: 11



« Reply #22 on: December 05, 2017, 07:15:03 PM »

Ok I will have a look at the MAF Sensor when I get a change. Sometimes on a cold start the Car stalls as soon as you start it and when I start it up again it's fine  Huh?
Report to moderator   Logged
Wilsh
Certified Post Ninja!


Karma: 5
Offline Offline

Posts: 1,058



« Reply #23 on: December 05, 2017, 08:52:01 PM »

Ok I will have a look at the MAF Sensor when I get a change. Sometimes on a cold start the Car stalls as soon as you start it and when I start it up again it's fine  Huh?

I had this a while ago as did a fair few people in Vic and was noted in qld. It turned out we all where using bp ultimate fuel. As soo. As I changed to shell vpower cold start issues went away.

It was to do with switching between winter and summer fuel.

So I guess my question is what fuel are you using?
Report to moderator   Logged

2006 Black LS; Pumaspeed M440, Motorcade RIP(modified 3")& CAI ; Forge CBV; Elevate TCV; Airtec Gen 3 IC; Pro-hose cold side pipe; PS Plenum; Mongoose 3" dump; Venom 200 cell cat; Xforce catback; RS clutch & Quaife; RS oil cooler; RS bonnet vents; RS injectors; Dba-T3 front &T2 rear discs; Brembo pads; HEL Braided brake Lines; Eibach b12's;  Whiteline antilift kit & 24mm RARB, DMB front, back, wheel overlays
XR5TURBOTRENT
Into the peak torque!


Karma: 0
Offline Offline

Posts: 11



« Reply #24 on: December 05, 2017, 09:51:04 PM »

I am using BP 98  Huh?
Report to moderator   Logged
Wilsh
Certified Post Ninja!


Karma: 5
Offline Offline

Posts: 1,058



« Reply #25 on: December 13, 2017, 04:50:55 AM »

I am using BP 98  Huh?

Did you replace with vpower yet?
Report to moderator   Logged

2006 Black LS; Pumaspeed M440, Motorcade RIP(modified 3")& CAI ; Forge CBV; Elevate TCV; Airtec Gen 3 IC; Pro-hose cold side pipe; PS Plenum; Mongoose 3" dump; Venom 200 cell cat; Xforce catback; RS clutch & Quaife; RS oil cooler; RS bonnet vents; RS injectors; Dba-T3 front &T2 rear discs; Brembo pads; HEL Braided brake Lines; Eibach b12's;  Whiteline antilift kit & 24mm RARB, DMB front, back, wheel overlays
XR5TURBOTRENT
Into the peak torque!


Karma: 0
Offline Offline

Posts: 11



« Reply #26 on: December 16, 2017, 09:11:46 AM »

That is what I will be doing it seems
Report to moderator   Logged
Pages: 1 [2]  All   Go Up
  Print  
 
Jump to: